In short
- CVE-2017-1000096 is a HIGH (CVSS 8.8) vulnerability affecting org.jenkins-ci.plugins.workflow:workflow-cps, pipeline (jenkins).
- Chance of exploitation in the next 30 days (EPSS): 1.6%, higher than 75.9% of all vulnerabilities.
- Fix: update to 2.36.1 or later.
Description
Arbitrary code execution due to incomplete sandbox protection: Constructors, instance variable initializers, and instance initializers in Pipeline scripts were not subject to sandbox protection, and could therefore execute arbitrary code. This could be exploited e.g. by regular Jenkins users with the permission to configure Pipelines in Jenkins, or by trusted committers to repositories containing Jenkinsfiles.
NVD description
Arbitrary code execution due to incomplete sandbox protection: Constructors, instance variable initializers, and instance initializers in Pipeline scripts were not subject to sandbox protection, and could therefore execute arbitrary code. This could be exploited e.g. by regular Jenkins users with the permission to configure Pipelines in Jenkins, or by trusted committers to repositories containing Jenkinsfiles.
More vulnerabilities in org.jenkins-ci.plugins.workflow:workflow-cps
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free