In short
- CVE-2017-1000102 is a MEDIUM (CVSS 5.4) vulnerability affecting org.jvnet.hudson.plugins:analysis-core, static analysis utilities (jenkins).
- Chance of exploitation in the next 30 days (EPSS): 0.74%, higher than 54.8% of all vulnerabilities.
- Fix: update to 1.92 or later.
Description
The Details view of some Static Analysis Utilities based plugins, was vulnerable to a persisted cross-site scripting vulnerability: Malicious users able to influence the input to these plugins, for example the console output which is parsed to extract build warnings (Warnings Plugin), could insert arbitrary HTML into this view.
NVD description
The Details view of some Static Analysis Utilities based plugins, was vulnerable to a persisted cross-site scripting vulnerability: Malicious users able to influence the input to these plugins, for example the console output which is parsed to extract build warnings (Warnings Plugin), could insert arbitrary HTML into this view.
More vulnerabilities in org.jvnet.hudson.plugins:analysis-core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free