In short
- CVE-2017-1000107 is a HIGH (CVSS 8.8) vulnerability affecting org.jenkins-ci.plugins:script-security, script security (jenkins).
- Chance of exploitation in the next 30 days (EPSS): 1.2%, higher than 68.3% of all vulnerabilities.
- Fix: update to 1.31 or later.
Description
Script Security Plugin did not apply sandboxing restrictions to constructor invocations via positional arguments list, super constructor invocations, method references, and type coercion expressions. This could be used to invoke arbitrary constructors and methods, bypassing sandbox protection.
NVD description
Script Security Plugin did not apply sandboxing restrictions to constructor invocations via positional arguments list, super constructor invocations, method references, and type coercion expressions. This could be used to invoke arbitrary constructors and methods, bypassing sandbox protection.
More vulnerabilities in org.jenkins-ci.plugins:script-security
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free