In short
- CVE-2017-1000114 is a LOW (CVSS 3.1) vulnerability affecting org.datadog.jenkins.plugins:datadog, datadog (jenkins).
- Chance of exploitation in the next 30 days (EPSS): 1.0%, higher than 64.0% of all vulnerabilities.
- Fix: update to 0.6.2 or later.
Description
The Datadog Plugin stores an API key to access the Datadog service in the global Jenkins configuration. While the API key is stored encrypted on disk, it was transmitted in plain text as part of the configuration form. This could result in exposure of the API key for example through browser extensions or cross-site scripting vulnerabilities. The Datadog Plugin now encrypts the API key transmitted to administrators viewing the global configuration form.
NVD description
The Datadog Plugin stores an API key to access the Datadog service in the global Jenkins configuration. While the API key is stored encrypted on disk, it was transmitted in plain text as part of the configuration form. This could result in exposure of the API key for example through browser extensions or cross-site scripting vulnerabilities. The Datadog Plugin now encrypts the API key transmitted to administrators viewing the global configuration form.
More vulnerabilities in org.datadog.jenkins.plugins:datadog
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free