In short
- CVE-2017-1000115 is a HIGH (CVSS 7.5) vulnerability affecting mercurial, mercurial (mercurial).
- Chance of exploitation in the next 30 days (EPSS): 4.8%, higher than 92.0% of all vulnerabilities.
- Fix: update to 4.3, 4.3.1 or later.
| Package | Affected versions | Patched versions |
|---|
| mercurial PyPI | < 4.3< 4.3.1
| 4.34.3.1
|
| mercurial | < 4.3
| 4.3
|
Description
Mercurial prior to version 4.3 is vulnerable to a missing symlink check that can malicious repositories to modify files outside the repository
NVD description
Mercurial prior to version 4.3 is vulnerable to a missing symlink check that can malicious repositories to modify files outside the repository
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free