In short
- CVE-2017-1000397 is a MEDIUM (CVSS 5.9) vulnerability affecting org.jenkins-ci.main:maven-plugin, maven (jenkins).
- Chance of exploitation in the next 30 days (EPSS): 0.49%, higher than 42.2% of all vulnerabilities.
- Fix: update to 3.0 or later.
Description
Jenkins Maven Plugin 2.17 and earlier bundled a version of the commons-httpclient library with the vulnerability CVE-2012-6153 that incorrectly verified SSL certificates, making it susceptible to man-in-the-middle attacks. Maven Plugin 3.0 no longer has a dependency on commons-httpclient.
NVD description
Jenkins Maven Plugin 2.17 and earlier bundled a version of the commons-httpclient library with the vulnerability CVE-2012-6153 that incorrectly verified SSL certificates, making it susceptible to man-in-the-middle attacks. Maven Plugin 3.0 no longer has a dependency on commons-httpclient.
More vulnerabilities in org.jenkins-ci.main:maven-plugin
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free