In short
- CVE-2017-1000424 is a MEDIUM (CVSS 4.3) vulnerability affecting electron (atom), electron.
- Chance of exploitation in the next 30 days (EPSS): 0.98%, higher than 62.3% of all vulnerabilities.
- Fix: update to 1.7.6 or later.
| Package | Affected versions | Patched versions |
|---|
| electron | ≥ 1.6.4, ≤ 1.6.11≥ 1.7.0, ≤ 1.7.5
| No fix yet |
| electron npm | ≥ 1.7.0, < 1.7.6
| 1.7.6
|
Description
Electron version 1.7.0 - 1.7.5 is vulnerable to a URL Spoofing problem when opening PDFs in PDFium resulting loading arbitrary PDFs that a hacker can control.
NVD description
Github Electron version 1.6.4 - 1.6.11 and 1.7.0 - 1.7.5 is vulnerable to a URL Spoofing problem when opening PDFs in PDFium resulting loading arbitrary PDFs that a hacker can control.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free