In short
- CVE-2017-1000502 is a HIGH (CVSS 8.8) vulnerability affecting org.jenkins-ci.plugins:ec2, ec2 (jenkins).
- Chance of exploitation in the next 30 days (EPSS): 1.6%, higher than 75.8% of all vulnerabilities.
- Fix: update to 1.38 or later.
Description
Users with permission to create or configure agents in Jenkins 1.37 and earlier could configure an EC2 agent to run arbitrary shell commands on the master node whenever the agent was supposed to be launched. Configuration of these agents now requires the 'Run Scripts' permission typically only granted to administrators.
NVD description
Users with permission to create or configure agents in Jenkins 1.37 and earlier could configure an EC2 agent to run arbitrary shell commands on the master node whenever the agent was supposed to be launched. Configuration of these agents now requires the 'Run Scripts' permission typically only granted to administrators.
More vulnerabilities in org.jenkins-ci.plugins:ec2
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free