In short
- CVE-2017-1001002 is a CRITICAL (CVSS 9.8) vulnerability affecting math.js (mathjs), mathjs.
- Chance of exploitation in the next 30 days (EPSS): 2.4%, higher than 83.8% of all vulnerabilities.
- Fix: update to 3.17.0 or later.
| Package | Affected versions | Patched versions |
|---|
| math.js | ≤ 3.17.0
| No fix yet |
| mathjs npm | < 3.17.0
| 3.17.0
|
Description
math.js before 3.17.0 had an arbitrary code execution in the JavaScript engine. Creating a typed function with JavaScript code in the name could result arbitrary execution.
Recommendation
Update to version 3.17.0 or later.
NVD description
math.js before 3.17.0 had an arbitrary code execution in the JavaScript engine. Creating a typed function with JavaScript code in the name could result arbitrary execution.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free