In short
- CVE-2017-1001003 is a CRITICAL (CVSS 9.8) vulnerability affecting mathjs (mathjs project), mathjs.
- Chance of exploitation in the next 30 days (EPSS): 1.7%, higher than 77.1% of all vulnerabilities.
- Fix: update to 3.17.0 or later.
| Package | Affected versions | Patched versions |
|---|
| mathjs | < 3.17.0
| 3.17.0
|
| mathjs npm | < 3.17.0
| 3.17.0
|
Description
math.js before 3.17.0 had an issue where private properties such as a constructor could be replaced by using unicode characters when creating an object.
Recommendation
Upgrade to version 3.17.0 or later.
NVD description
math.js before 3.17.0 had an issue where private properties such as a constructor could be replaced by using unicode characters when creating an object.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free