In short
- CVE-2017-1002201 is a MEDIUM (CVSS 6.1) vulnerability affecting haml, haml (haml).
- Chance of exploitation in the next 30 days (EPSS): 1.5%, higher than 73.6% of all vulnerabilities.
- Fix: update to 5.0.0 or later.
| Package | Affected versions | Patched versions |
|---|
| haml RubyGems | < 5.0.0
| 5.0.0
|
| haml | < 5.0.0
| 5.0.0
|
Description
In haml versions prior to version 5.0.0.beta.2, when using user input to perform tasks on the server, characters like < > " ' must be escaped properly. In this case, the ' character was missed. An attacker can manipulate the input to introduce additional attributes, potentially executing code.
NVD description
In haml versions prior to version 5.0.0.beta.2, when using user input to perform tasks on the server, characters like < > " ' must be escaped properly. In this case, the ' character was missed. An attacker can manipulate the input to introduce additional attributes, potentially executing code.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free