In short
- CVE-2017-11424 is a HIGH (CVSS 7.5) vulnerability affecting pyjwt, pyjwt (pyjwt project).
- Chance of exploitation in the next 30 days (EPSS): 1.8%, higher than 78.6% of all vulnerabilities.
- Fix: update to 1.5.1 or later.
| Package | Affected versions | Patched versions |
|---|
| pyjwt PyPI | < 1.5.1
| 1.5.1
|
| pyjwt | ≤ 1.5.0
| No fix yet |
Description
In PyJWT 1.5.0 and below the invalid_strings check in HMACAlgorithm.prepare_key does not account for all PEM encoded public keys. Specifically, the PKCS1 PEM encoded format would be allowed because it is prefaced with the string -----BEGIN RSA PUBLIC KEY----- which is not accounted for. This enables symmetric/asymmetric key confusion attacks against users using the PKCS1 PEM encoded public keys, which would allow an attacker to craft JWTs from scratch.
NVD description
In PyJWT 1.5.0 and below the `invalid_strings` check in `HMACAlgorithm.prepare_key` does not account for all PEM encoded public keys. Specifically, the PKCS1 PEM encoded format would be allowed because it is prefaced with the string `-----BEGIN RSA PUBLIC KEY-----` which is not accounted for. This enables symmetric/asymmetric key confusion attacks against users using the PKCS1 PEM encoded public keys, which would allow an attacker to craft JWTs from scratch.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free