In short
- CVE-2017-11428 is a CRITICAL (CVSS 9.8) vulnerability affecting ruby-saml, ruby-saml (onelogin).
- Chance of exploitation in the next 30 days (EPSS): 2.5%, higher than 84.5% of all vulnerabilities.
- Fix: update to 1.7.0 or later.
| Package | Affected versions | Patched versions |
|---|
| ruby-saml RubyGems | < 1.7.0
| 1.7.0
|
| ruby-saml | ≤ 1.6.0
| No fix yet |
Description
OneLogin Ruby-SAML 1.6.0 and earlier may incorrectly utilize the results of XML DOM traversal and canonicalization APIs in such a way that an attacker may be able to manipulate the SAML data without invalidating the cryptographic signature, allowing the attack to potentially bypass authentication to SAML service providers.
NVD description
OneLogin Ruby-SAML 1.6.0 and earlier may incorrectly utilize the results of XML DOM traversal and canonicalization APIs in such a way that an attacker may be able to manipulate the SAML data without invalidating the cryptographic signature, allowing the attack to potentially bypass authentication to SAML service providers.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free