In short
- CVE-2017-11430 is a CRITICAL (CVSS 9.8) vulnerability affecting omniauth-saml, omniauth saml (omniauth).
- Chance of exploitation in the next 30 days (EPSS): 2.4%, higher than 84.3% of all vulnerabilities.
- Fix: update to 1.10.0 or later.
Description
OmniAuth OmniAuth-SAML 1.9.0 and earlier may incorrectly utilize the results of XML DOM traversal and canonicalization APIs in such a way that an attacker may be able to manipulate the SAML data without invalidating the cryptographic signature, allowing the attack to potentially bypass authentication to SAML service providers.
NVD description
OmniAuth OmnitAuth-SAML 1.9.0 and earlier may incorrectly utilize the results of XML DOM traversal and canonicalization APIs in such a way that an attacker may be able to manipulate the SAML data without invalidating the cryptographic signature, allowing the attack to potentially bypass authentication to SAML service providers.
More vulnerabilities in omniauth-saml
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free