In short
- CVE-2017-12610 is a MEDIUM (CVSS 6.8) vulnerability affecting org.apache.kafka:kafka-clients, kafka (apache).
- Chance of exploitation in the next 30 days (EPSS): 2.9%, higher than 86.8% of all vulnerabilities.
- Fix: update to 0.10.2.2, 0.11.0.2 or later.
| Package | Affected versions | Patched versions |
|---|
| org.apache.kafka:kafka-clients Maven | ≥ 0.10.0.0, < 0.10.2.2≥ 0.11.0.0, < 0.11.0.2
| 0.10.2.20.11.0.2
|
| kafka | ≥ 0.10.0.0, ≤ 0.10.2.1≥ 0.11.0.0, ≤ 0.11.0.1
| No fix yet |
Description
In Apache Kafka 0.10.0.0 to 0.10.2.1 and 0.11.0.0 to 0.11.0.1, authenticated Kafka clients may use impersonation via a manually crafted protocol message with SASL/PLAIN or SASL/SCRAM authentication when using the built-in PLAIN or SCRAM server implementations in Apache Kafka.
NVD description
In Apache Kafka 0.10.0.0 to 0.10.2.1 and 0.11.0.0 to 0.11.0.1, authenticated Kafka clients may use impersonation via a manually crafted protocol message with SASL/PLAIN or SASL/SCRAM authentication when using the built-in PLAIN or SCRAM server implementations in Apache Kafka.
More vulnerabilities in org.apache.kafka:kafka-clients
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free