In short
- CVE-2017-12870 is a MEDIUM (CVSS 5.9) vulnerability affecting simplesamlphp/simplesamlphp, simplesamlphp (simplesamlphp).
- Chance of exploitation in the next 30 days (EPSS): 0.88%, higher than 59.0% of all vulnerabilities.
- Fix: update to 1.14.13 or later.
Description
SimpleSAMLphp 1.14.12 and earlier make it easier for man-in-the-middle attackers to obtain sensitive information by leveraging use of the aesEncrypt and aesDecrypt methods in the SimpleSAML/Utils/Crypto class to protect session identifiers in replies to non-HTTPS service providers.
NVD description
SimpleSAMLphp 1.14.12 and earlier make it easier for man-in-the-middle attackers to obtain sensitive information by leveraging use of the aesEncrypt and aesDecrypt methods in the SimpleSAML/Utils/Crypto class to protect session identifiers in replies to non-HTTPS service providers.
More vulnerabilities in simplesamlphp/simplesamlphp
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free