In short
- CVE-2017-12871 is a MEDIUM (CVSS 5.9) vulnerability affecting simplesamlphp/simplesamlphp, simplesamlphp (simplesamlphp).
- Chance of exploitation in the next 30 days (EPSS): 0.49%, higher than 42.1% of all vulnerabilities.
- Fix: update to 1.14.12 or later.
| Package | Affected versions | Patched versions |
|---|
| simplesamlphp/simplesamlphp Packagist | ≥ 1.14.0, < 1.14.12
| 1.14.12
|
| simplesamlphp | = 1.14.0= 1.14.1= 1.14.10= 1.14.11= 1.14.2= 1.14.3= 1.14.4= 1.14.5= 1.14.6= 1.14.7= 1.14.8= 1.14.9
| No fix yet |
Description
The aesEncrypt method in lib/SimpleSAML/Utils/Crypto.php in SimpleSAMLphp 1.14.x through 1.14.11 makes it easier for context-dependent attackers to bypass the encryption protection mechanism by leveraging use of the first 16 bytes of the secret key as the initialization vector (IV).
NVD description
The aesEncrypt method in lib/SimpleSAML/Utils/Crypto.php in SimpleSAMLphp 1.14.x through 1.14.11 makes it easier for context-dependent attackers to bypass the encryption protection mechanism by leveraging use of the first 16 bytes of the secret key as the initialization vector (IV).
More vulnerabilities in simplesamlphp/simplesamlphp
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free