In short
- CVE-2017-14623 is a HIGH (CVSS 8.1) vulnerability affecting github.com/go-ldap/ldap, ldap (go-ldap project).
- Chance of exploitation in the next 30 days (EPSS): 1.7%, higher than 77.1% of all vulnerabilities.
- Fix: update to 2.5.0, 2.5.0+incompatible or later.
| Package | Affected versions | Patched versions |
|---|
| github.com/go-ldap/ldap Go | < 2.5.0< 2.5.0+incompatible
| 2.5.02.5.0+incompatible
|
| ldap | ≤ 2.5.0
| No fix yet |
Description
In the ldap.v2 (aka go-ldap) package through 2.5.0 for Go, an attacker may be able to login with an empty password. This issue affects an application using this package if these conditions are met: (1) it relies only on the return error of the Bind function call to determine whether a user is authorized (i.e., a nil return value is interpreted as successful authorization) and (2) it is used with an LDAP server allowing unauthenticated bind.
NVD description
In the ldap.v2 (aka go-ldap) package through 2.5.0 for Go, an attacker may be able to login with an empty password. This issue affects an application using this package if these conditions are met: (1) it relies only on the return error of the Bind function call to determine whether a user is authorized (i.e., a nil return value is interpreted as successful authorization) and (2) it is used with an LDAP server allowing unauthenticated bind.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free