In short
- CVE-2017-15110 is a MEDIUM (CVSS 4.3) vulnerability affecting moodle/moodle, moodle (moodle).
- Chance of exploitation in the next 30 days (EPSS): 1.2%, higher than 67.1% of all vulnerabilities.
- Fix: update to 3.1.9, 3.2.6, 3.3.3 or later.
| Package | Affected versions | Patched versions |
|---|
| moodle/moodle Packagist | ≥ 3.1, < 3.1.9≥ 3.2, < 3.2.6≥ 3.3, < 3.3.3
| 3.1.93.2.63.3.3
|
| moodle | ≥ 3.1, ≤ 3.1.8≥ 3.2, ≤ 3.2.5≥ 3.3, ≤ 3.3.2≤ 3.0.10
| No fix yet |
Description
In Moodle 3.x, students can find out email addresses of other students in the same course. Using search on the Participants page, students could search email addresses of all participants regardless of email visibility. This allows enumerating and guessing emails of other students.
NVD description
In Moodle 3.x, students can find out email addresses of other students in the same course. Using search on the Participants page, students could search email addresses of all participants regardless of email visibility. This allows enumerating and guessing emails of other students.
More vulnerabilities in moodle/moodle
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free