In short
- CVE-2017-15412 is a HIGH (CVSS 8.8) vulnerability affecting nokogiri, chrome (google), libxml2 (xmlsoft).
- Chance of exploitation in the next 30 days (EPSS): 2.9%, higher than 87.1% of all vulnerabilities.
- Fix: update to 1.8.2, 63.0.3239.84, 2.9.5 or later.
| Package | Affected versions | Patched versions |
|---|
| nokogiri RubyGems | < 1.8.2
| 1.8.2
|
| chrome | < 63.0.3239.84
| 63.0.3239.84
|
| libxml2 | < 2.9.5
| 2.9.5
|
Description
Use after free in libxml2 before 2.9.5, as used in Google Chrome prior to 63.0.3239.84 and other products, allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page.
NVD description
Use after free in libxml2 before 2.9.5, as used in Google Chrome prior to 63.0.3239.84 and other products, allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free