In short
- CVE-2017-15911 is a MEDIUM (CVSS 4.8) vulnerability affecting org.igniterealtime.openfire:parent, openfire (igniterealtime).
- Chance of exploitation in the next 30 days (EPSS): 0.73%, higher than 54.2% of all vulnerabilities.
- Fix: update to 4.1.7 or later.
Description
The Admin Console in Ignite Realtime Openfire Server before 4.1.7 allows arbitrary client-side JavaScript code execution on victims who click a crafted setup/setup-host-settings.jsp?domain= link, aka XSS. Session ID and data theft may follow as well as the possibility of bypassing CSRF protections, injection of iframes to establish communication channels, etc. The vulnerability is present after login into the application.
NVD description
The Admin Console in Ignite Realtime Openfire Server before 4.1.7 allows arbitrary client-side JavaScript code execution on victims who click a crafted setup/setup-host-settings.jsp?domain= link, aka XSS. Session ID and data theft may follow as well as the possibility of bypassing CSRF protections, injection of iframes to establish communication channels, etc. The vulnerability is present after login into the application.
More vulnerabilities in org.igniterealtime.openfire:parent
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free