In short
- CVE-2017-16029 is a HIGH (CVSS 7.5) vulnerability affecting hostr (hostr project), hostr.
- Chance of exploitation in the next 30 days (EPSS): 1.8%, higher than 78.6% of all vulnerabilities.
- Fix: update to 2.3.6 or later.
| Package | Affected versions | Patched versions |
|---|
| hostr | ≤ 2.3.5
| No fix yet |
| hostr npm | < 2.3.6
| 2.3.6
|
Description
Affected versions of hostr are vulnerable to directory traversal which allows attackers to read files outside the current directory by sending ../ in the url path for GET requests.
Recommendation
Upgrade to version 2.3.6 or later.
NVD description
hostr is a simple web server that serves up the contents of the current directory. There is a directory traversal vulnerability in hostr 2.3.5 and earlier that allows an attacker to read files outside the current directory by sending `../` in the url path for GET requests.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free