In short
- CVE-2017-16043 is a MEDIUM (CVSS 6.1) vulnerability affecting shout (shout project), shout.
- Chance of exploitation in the next 30 days (EPSS): 1.00%, higher than 63.0% of all vulnerabilities.
- Fix: update to 0.50.0 or later.
| Package | Affected versions | Patched versions |
|---|
| shout | ≥ 0.44.0, < 0.50.0
| 0.50.0
|
| shout npm | ≥ 0.44.0, < 0.50.0
| 0.50.0
|
Description
Affected versions of shout do not escape the /topic command in messages, and are therefore vulnerable to cross-site scripting.
Recommendation
Update to version 0.50.0 or later.
NVD description
Shout is an IRC client. Because the `/topic` command in messages is unescaped, attackers have the ability to inject HTML scripts that will run in the victim's browser. Affects shout >=0.44.0 <=0.49.3.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free