In short
- CVE-2017-16099 is a HIGH (CVSS 7.5) vulnerability affecting no-case (no-case project), no-case.
- Chance of exploitation in the next 30 days (EPSS): 1.6%, higher than 75.4% of all vulnerabilities.
- Fix: update to 2.3.2 or later.
| Package | Affected versions | Patched versions |
|---|
| no-case | < 2.3.2
| 2.3.2
|
| no-case npm | < 2.3.2
| 2.3.2
|
Description
Affected versions of no-case are vulnerable to a regular expression denial of service when parsing untrusted user input.
Recommendation
Update to version 2.3.2 or later.
NVD description
The no-case module is vulnerable to regular expression denial of service. When malicious untrusted user input is passed into no-case it can block the event loop causing a denial of service condition.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free