| Package | Affected versions | Patched versions |
|---|---|---|
| pooledwebsocket | ≥ 0.0.1, ≤ 0.0.18 | |
| pooledwebsocket | < 0.0.19 | 0.0.19 |
Affected versions of pooledwebsocket resolve relative file paths, resulting in a directory traversal vulnerability. A malicious actor can use this vulnerability to access files outside of the intended directory root, which may result in the disclosure of private files on the vulnerable system.
Example request:
GET /../../../../../../../../../../etc/passwd HTTP/1.1
host:foo
Update to version 0.0.19 or later.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free