In short
- CVE-2017-16117 is a HIGH (CVSS 7.5) vulnerability affecting slug (slug project), slug.
- Chance of exploitation in the next 30 days (EPSS): 1.6%, higher than 75.4% of all vulnerabilities.
- Fix: update to 0.9.2 or later.
| Package | Affected versions | Patched versions |
|---|
| slug | ≤ 0.9.1
| No fix yet |
| slug npm | < 0.9.2
| 0.9.2
|
Description
Affected versions of slug are vulnerable to a regular expression denial of service when parsing untrusted user input.
The issue is low severity, as it takes 50,000 characters to cause the event loop to block for 2 seconds,
About 50k characters can block the event loop for 2 seconds.
Recommendation
Update to version 0.9.2 or later.
NVD description
slug is a module to slugify strings, even if they contain unicode. slug is vulnerable to regular expression denial of service is specially crafted untrusted input is passed as input. About 50k characters can block the event loop for 2 seconds.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free