In short
- CVE-2017-16119 is a HIGH (CVSS 7.5) vulnerability affecting fresh (fresh project), fresh.
- Chance of exploitation in the next 30 days (EPSS): 1.6%, higher than 75.6% of all vulnerabilities.
- Fix: update to 0.5.2 or later.
| Package | Affected versions | Patched versions |
|---|
| fresh | < 0.5.2
| 0.5.2
|
| fresh npm | < 0.5.2
| 0.5.2
|
Description
Affected versions of fresh are vulnerable to regular expression denial of service when parsing specially crafted user input.
Recommendation
Update to version 0.5.2 or later.
NVD description
Fresh is a module used by the Express.js framework for HTTP response freshness testing. It is vulnerable to a regular expression denial of service when it is passed specially crafted input to parse. This causes the event loop to be blocked causing a denial of service condition.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free