In short
- CVE-2017-16136 is a HIGH (CVSS 7.5) vulnerability affecting method-override (expressjs), method-override.
- Chance of exploitation in the next 30 days (EPSS): 1.2%, higher than 68.1% of all vulnerabilities.
- Fix: update to 2.3.10 or later.
Description
Affected versions of method-override are vulnerable to a regular expression denial of service vulnerability when untrusted user input is passed into the X-HTTP-Method-Override header.
Recommendation
Update to version 2.3.10 or later
NVD description
method-override is a module used by the Express.js framework to let you use HTTP verbs such as PUT or DELETE in places where the client doesn't support it. method-override is vulnerable to a regular expression denial of service vulnerability when specially crafted input is passed in to be parsed via the X-HTTP-Method-Override header.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free