In short
- CVE-2017-16228 is a CRITICAL (CVSS 9.8) vulnerability affecting dulwich, dulwich (dulwich project).
- Chance of exploitation in the next 30 days (EPSS): 3.8%, higher than 90.1% of all vulnerabilities.
- Fix: update to 0.18.5 or later.
| Package | Affected versions | Patched versions |
|---|
| dulwich PyPI | < 0.18.5
| 0.18.5
|
| dulwich | ≤ 0.18.4
| No fix yet |
Description
Dulwich before 0.18.5, when an SSH subprocess is used, allows remote attackers to execute arbitrary commands via an ssh URL with an initial dash character in the hostname, a related issue to CVE-2017-9800, CVE-2017-12836, CVE-2017-12976, CVE-2017-1000116, and CVE-2017-1000117.
NVD description
Dulwich before 0.18.5, when an SSH subprocess is used, allows remote attackers to execute arbitrary commands via an ssh URL with an initial dash character in the hostname, a related issue to CVE-2017-9800, CVE-2017-12836, CVE-2017-12976, CVE-2017-1000116, and CVE-2017-1000117.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free