In short
- CVE-2017-16516 is a HIGH (CVSS 7.5) vulnerability affecting yajl-ruby, yajl-ruby (yajl-ruby project).
- Chance of exploitation in the next 30 days (EPSS): 3.8%, higher than 90.0% of all vulnerabilities.
- Fix: update to 1.3.1 or later.
| Package | Affected versions | Patched versions |
|---|
| yajl-ruby RubyGems | < 1.3.1
| 1.3.1
|
| yajl-ruby | = 1.3.0
| No fix yet |
Description
In the yajl-ruby gem 1.3.0 for Ruby, when a crafted JSON file is supplied to Yajl::Parser.new.parse, the whole ruby process crashes with a SIGABRT in the yajl_string_decode function in yajl_encode.c. This results in the whole ruby process terminating and potentially a denial of service.
NVD description
In the yajl-ruby gem 1.3.0 for Ruby, when a crafted JSON file is supplied to Yajl::Parser.new.parse, the whole ruby process crashes with a SIGABRT in the yajl_string_decode function in yajl_encode.c. This results in the whole ruby process terminating and potentially a denial of service.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free