In short
- CVE-2017-16616 is a CRITICAL (CVSS 9.8) vulnerability affecting pyanyapi, pyanyapi (pyanyapi project).
- Chance of exploitation in the next 30 days (EPSS): 3.6%, higher than 89.6% of all vulnerabilities.
- Fix: update to 0.6.1 or later.
| Package | Affected versions | Patched versions |
|---|
| pyanyapi PyPI | < 0.6.1
| 0.6.1
|
| pyanyapi | < 0.6.1
| 0.6.1
|
Description
An exploitable vulnerability exists in the YAML parsing functionality in the YAMLParser method in Interfaces.py in PyAnyAPI before 0.6.1. A YAML parser can execute arbitrary Python commands resulting in command execution because load is used where safe_load should have been used. An attacker can insert Python into loaded YAML to trigger this vulnerability.
NVD description
An exploitable vulnerability exists in the YAML parsing functionality in the YAMLParser method in Interfaces.py in PyAnyAPI before 0.6.1. A YAML parser can execute arbitrary Python commands resulting in command execution because load is used where safe_load should have been used. An attacker can insert Python into loaded YAML to trigger this vulnerability.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free