In short
- CVE-2017-16618 is a CRITICAL (CVSS 9.8) vulnerability affecting owlmixin, owlmixin (owlmixin project).
- Chance of exploitation in the next 30 days (EPSS): 4.5%, higher than 91.5% of all vulnerabilities.
- Fix: update to 2.0.0 or later.
| Package | Affected versions | Patched versions |
|---|
| owlmixin PyPI | < 2.0.0
| 2.0.0
|
| owlmixin | = 2.0.0< 2.0.0
| 2.0.0
|
Description
An exploitable vulnerability exists in the YAML loading functionality of util.py in OwlMixin before 2.0.0a12. A "Load YAML" string or file (aka load_yaml or load_yamlf) can execute arbitrary Python commands resulting in command execution because load is used where safe_load should have been used. An attacker can insert Python into loaded YAML to trigger this vulnerability.
NVD description
An exploitable vulnerability exists in the YAML loading functionality of util.py in OwlMixin before 2.0.0a12. A "Load YAML" string or file (aka load_yaml or load_yamlf) can execute arbitrary Python commands resulting in command execution because load is used where safe_load should have been used. An attacker can insert Python into loaded YAML to trigger this vulnerability.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free