In short
- CVE-2017-16762 is a HIGH (CVSS 7.5) vulnerability affecting sanic, sanic (sanic project).
- Chance of exploitation in the next 30 days (EPSS): 2.4%, higher than 84.4% of all vulnerabilities.
- Fix: update to 0.5.1 or later.
| Package | Affected versions | Patched versions |
|---|
| sanic PyPI | < 0.5.1
| 0.5.1
|
| sanic | ≤ 0.5.0
| No fix yet |
Description
Sanic before 0.5.1 allows reading arbitrary files with directory traversal, as demonstrated by the /static/..%2f substring.
NVD description
Sanic before 0.5.1 allows reading arbitrary files with directory traversal, as demonstrated by the /static/..%2f substring.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free