In short
- CVE-2017-16932 is a HIGH (CVSS 7.5) vulnerability affecting nokogiri, libxml2 (xmlsoft).
- Chance of exploitation in the next 30 days (EPSS): 6.5%, higher than 93.7% of all vulnerabilities.
- Fix: update to 1.8.1 or later.
| Package | Affected versions | Patched versions |
|---|
| nokogiri RubyGems | < 1.8.1
| 1.8.1
|
| libxml2 | ≤ 2.9.4
| No fix yet |
Description
parser.c in libxml2 before 2.9.5 does not prevent infinite recursion in parameter entities.
NVD description
parser.c in libxml2 before 2.9.5 does not prevent infinite recursion in parameter entities.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free