In short
- CVE-2017-17042 is a HIGH (CVSS 7.5) vulnerability affecting yard, yard (yardoc).
- Chance of exploitation in the next 30 days (EPSS): 2.9%, higher than 87.0% of all vulnerabilities.
- Fix: update to 0.9.11 or later.
| Package | Affected versions | Patched versions |
|---|
| yard RubyGems | < 0.9.11
| 0.9.11
|
| yard | < 0.9.11
| 0.9.11
|
Description
lib/yard/core_ext/file.rb in the server in YARD before 0.9.11 does not block relative paths with an initial ../ sequence, which allows attackers to conduct directory traversal attacks and read arbitrary files.
NVD description
lib/yard/core_ext/file.rb in the server in YARD before 0.9.11 does not block relative paths with an initial ../ sequence, which allows attackers to conduct directory traversal attacks and read arbitrary files.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free