In short
- CVE-2017-18049 is a MEDIUM (CVSS 5.5) vulnerability affecting silverstripe/framework, silverstripe (silverstripe).
- Chance of exploitation in the next 30 days (EPSS): 0.90%, higher than 59.6% of all vulnerabilities.
- Fix: update to 3.6.3, 4.0.1, 3.5.6 or later.
| Package | Affected versions | Patched versions |
|---|
| silverstripe/framework Packagist | ≥ 3.6.0, < 3.6.3≥ 4.0.0, < 4.0.1< 3.5.6
| 3.6.34.0.13.5.6
|
| silverstripe | = 4.0.0≥ 3.6.0, ≤ 3.6.2≤ 3.5.5
| No fix yet |
Description
In the CSV export feature of SilverStripe before 3.5.6, 3.6.x before 3.6.3, and 4.x before 4.0.1, it's possible for the output to contain macros and scripts, which may be executed if imported without sanitization into common software (including Microsoft Excel). For example, the CSV data may contain untrusted user input from the "First Name" field of a user's /myprofile page.
NVD description
In the CSV export feature of SilverStripe before 3.5.6, 3.6.x before 3.6.3, and 4.x before 4.0.1, it's possible for the output to contain macros and scripts, which may be executed if imported without sanitization into common software (including Microsoft Excel). For example, the CSV data may contain untrusted user input from the "First Name" field of a user's /myprofile page.
More vulnerabilities in silverstripe/framework
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free