In short
- CVE-2017-18197 is a CRITICAL (CVSS 9.8) vulnerability affecting mxgraph (jgraph), mxgraph.
- Chance of exploitation in the next 30 days (EPSS): 2.9%, higher than 87.0% of all vulnerabilities.
- Fix: update to 3.7.6 or later.
| Package | Affected versions | Patched versions |
|---|
| mxgraph | ≤ 3.7.5
| No fix yet |
| mxgraph npm | < 3.7.6
| 3.7.6
|
Description
In mxGraphViewImageReader.java in mxGraph before 3.7.6, the SAXParserFactory instance in convert() is missing flags to prevent XML External Entity (XXE) attacks, as demonstrated by /ServerView.
NVD description
In mxGraphViewImageReader.java in mxGraph before 3.7.6, the SAXParserFactory instance in convert() is missing flags to prevent XML External Entity (XXE) attacks, as demonstrated by /ServerView.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free