In short
- CVE-2017-18258 is a MEDIUM (CVSS 6.5) vulnerability affecting nokogiri, libxml2 (xmlsoft).
- Chance of exploitation in the next 30 days (EPSS): 2.7%, higher than 86.2% of all vulnerabilities.
- Fix: update to 1.8.2, 2.9.6 or later.
| Package | Affected versions | Patched versions |
|---|
| nokogiri RubyGems | < 1.8.2
| 1.8.2
|
| libxml2 | < 2.9.6
| 2.9.6
|
Description
The xz_head function in xzlib.c in libxml2 before 2.9.6 allows remote attackers to cause a denial of service (memory consumption) via a crafted LZMA file, because the decoder functionality does not restrict memory usage to what is required for a legitimate file.
NVD description
The xz_head function in xzlib.c in libxml2 before 2.9.6 allows remote attackers to cause a denial of service (memory consumption) via a crafted LZMA file, because the decoder functionality does not restrict memory usage to what is required for a legitimate file.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free