In short
- CVE-2017-18361 is a HIGH (CVSS 7.5) vulnerability affecting colander, colander (pylonsproject).
- Chance of exploitation in the next 30 days (EPSS): 2.1%, higher than 81.5% of all vulnerabilities.
- Fix: update to 1.7.0 or later.
| Package | Affected versions | Patched versions |
|---|
| colander PyPI | < 1.7.0
| 1.7.0
|
| colander | ≤ 1.6
| No fix yet |
Description
In Pylons Colander through 1.6, the URL validator allows an attacker to potentially cause an infinite loop thereby causing a denial of service via an unclosed parenthesis.
NVD description
In Pylons Colander through 1.6, the URL validator allows an attacker to potentially cause an infinite loop thereby causing a denial of service via an unclosed parenthesis.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free