In short
- CVE-2017-18869 is a LOW (CVSS 2.5) vulnerability affecting chownr (chownr project), chownr.
- Chance of exploitation in the next 30 days (EPSS): 0.33%, higher than 26.9% of all vulnerabilities.
- Fix: update to 1.1.0 or later.
| Package | Affected versions | Patched versions |
|---|
| chownr | < 1.1.0
| 1.1.0
|
| chownr npm | < 1.1.0
| 1.1.0
|
Description
A TOCTOU issue in the chownr package before 1.1.0 for Node.js 10.10 could allow a local attacker to trick it into descending into unintended directories via symlink attacks.
NVD description
A TOCTOU issue in the chownr package before 1.1.0 for Node.js 10.10 could allow a local attacker to trick it into descending into unintended directories via symlink attacks.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free