In short
- CVE-2017-20189 is a CRITICAL (CVSS 9.8) vulnerability affecting org.clojure:clojure, clojure (clojure).
- Chance of exploitation in the next 30 days (EPSS): 1.3%, higher than 71.2% of all vulnerabilities.
- Fix: update to 1.9.0 or later.
Description
In Clojure before 1.9.0, classes can be used to construct a serialized object that executes arbitrary code upon deserialization. This is relevant if a server deserializes untrusted objects.
NVD description
In Clojure before 1.9.0, classes can be used to construct a serialized object that executes arbitrary code upon deserialization. This is relevant if a server deserializes untrusted objects.
More vulnerabilities in org.clojure:clojure
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free