In short
- CVE-2017-2594 is a HIGH (CVSS 7.5) vulnerability affecting io.hawt:project, hawtio (hawt).
- Chance of exploitation in the next 30 days (EPSS): 1.8%, higher than 79.1% of all vulnerabilities.
- Fix: update to 1.5.0 or later.
Description
hawtio before versions 2.0-beta-1, 2.0-beta-2, 2.0-m1, 2.0-m2, 2.0-m3, and 1.5 are vulnerable to a path traversal that leads to a NullPointerException with a full stacktrace. An attacker could use this flaw to gather undisclosed information from within hawtio's root.
NVD description
hawtio before versions 2.0-beta-1, 2.0-beta-2 2.0-m1, 2.0-m2, 2.0-m3, and 1.5 is vulnerable to a path traversal that leads to a NullPointerException with a full stacktrace. An attacker could use this flaw to gather undisclosed information from within hawtio's root.
More vulnerabilities in io.hawt:project
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free