In short
- CVE-2017-3163 is a HIGH (CVSS 7.5) vulnerability affecting org.apache.solr:solr-core, solr (apache).
- Chance of exploitation in the next 30 days (EPSS): 6.6%, higher than 93.8% of all vulnerabilities.
- Fix: update to 6.4.1, 5.5.4 or later.
| Package | Affected versions | Patched versions |
|---|
| org.apache.solr:solr-core Maven | ≥ 6.0.0, < 6.4.1< 5.5.4
| 6.4.15.5.4
|
| solr | = 6.0.0= 6.0.1= 6.1.0= 6.2.0= 6.2.1= 6.3.0= 6.4.0≤ 5.5.3
| No fix yet |
Description
When using the Index Replication feature, Apache Solr nodes can pull index files from a master/leader node using an HTTP API which accepts a file name. However, Solr before 5.5.4 and 6.x before 6.4.1 did not validate the file name, hence it was possible to craft a special request involving path traversal, leaving any file readable to the Solr server process exposed. Solr servers protected and restricted by firewall rules and/or authentication would not be at risk since only trusted clients and users would gain direct HTTP access.
NVD description
When using the Index Replication feature, Apache Solr nodes can pull index files from a master/leader node using an HTTP API which accepts a file name. However, Solr before 5.5.4 and 6.x before 6.4.1 did not validate the file name, hence it was possible to craft a special request involving path traversal, leaving any file readable to the Solr server process exposed. Solr servers protected and restricted by firewall rules and/or authentication would not be at risk since only trusted clients and users would gain direct HTTP access.
More vulnerabilities in org.apache.solr:solr-core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free