In short
- CVE-2017-3165 is a MEDIUM (CVSS 5.4) vulnerability affecting org.apache.brooklyn:brooklyn, brooklyn (apache).
- Chance of exploitation in the next 30 days (EPSS): 2.2%, higher than 82.8% of all vulnerabilities.
- Fix: update to 0.10.0 or later.
Description
In Apache Brooklyn before 0.10.0, the REST server is vulnerable to cross-site scripting where one authenticated user can cause scripts to run in the browser of another user authorized to access the first user's resources. This is due to improper escaping of server-side content. There is known to be a proof-of-concept exploit using this vulnerability.
NVD description
In Apache Brooklyn before 0.10.0, the REST server is vulnerable to cross-site scripting where one authenticated user can cause scripts to run in the browser of another user authorized to access the first user's resources. This is due to improper escaping of server-side content. There is known to be a proof-of-concept exploit using this vulnerability.
More vulnerabilities in org.apache.brooklyn:brooklyn
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free