In short
- CVE-2017-5029 is a HIGH (CVSS 8.8) vulnerability affecting nokogiri, chrome (google), libxslt (xmlsoft).
- Chance of exploitation in the next 30 days (EPSS): 2.2%, higher than 82.2% of all vulnerabilities.
- Fix: update to 1.7.2 or later.
| Package | Affected versions | Patched versions |
|---|
| nokogiri RubyGems | < 1.7.2
| 1.7.2
|
| chrome | ≤ 57.0.2987.100≤ 57.0.2987.75
| No fix yet |
| libxslt | = 1.1.29
| No fix yet |
Description
The xsltAddTextString function in transform.c in libxslt 1.1.29, as used in Nokogiri prior to 1.7.2, lacked a check for integer overflow during a size calculation, which allowed a remote attacker to perform an out of bounds memory write via a crafted HTML page.
NVD description
The xsltAddTextString function in transform.c in libxslt 1.1.29, as used in Blink in Google Chrome prior to 57.0.2987.98 for Mac, Windows, and Linux and 57.0.2987.108 for Android, lacked a check for integer overflow during a size calculation, which allowed a remote attacker to perform an out of bounds memory write via a crafted HTML page.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free