In short
- CVE-2017-6923 is a MEDIUM (CVSS 6.5) vulnerability affecting drupal/core, drupal/drupal, drupal (drupal).
- Chance of exploitation in the next 30 days (EPSS): 2.0%, higher than 81.0% of all vulnerabilities.
- Fix: update to 8.3.7 or later.
| Package | Affected versions | Patched versions |
|---|
| drupal/core Packagist | ≥ 8.0, < 8.3.7
| 8.3.7
|
| drupal/drupal Packagist | ≥ 8.0, < 8.3.7
| 8.3.7
|
| drupal | ≥ 8.0.0, ≤ 8.3.7
| No fix yet |
Description
In Drupal 8.x prior to 8.3.7 When creating a view, you can optionally use Ajax to update the displayed data via filter parameters. The views subsystem/module did not restrict access to the Ajax endpoint to only views configured to use Ajax. This is mitigated if you have access restrictions on the view. It is best practice to always include some form of access restrictions on all views, even if you are using another module to display them.
NVD description
In Drupal 8.x prior to 8.3.7 When creating a view, you can optionally use Ajax to update the displayed data via filter parameters. The views subsystem/module did not restrict access to the Ajax endpoint to only views configured to use Ajax. This is mitigated if you have access restrictions on the view. It is best practice to always include some form of access restrictions on all views, even if you are using another module to display them.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free