In short
- CVE-2017-7251 is a MEDIUM (CVSS 6.1) vulnerability affecting pi/pi, pi (piengine).
- Chance of exploitation in the next 30 days (EPSS): 0.98%, higher than 62.4% of all vulnerabilities.
- Fix: update to 2.6.0-alpha1 or later.
| Package | Affected versions | Patched versions |
|---|
| pi/pi Packagist | < 2.6.0-alpha1
| 2.6.0-alpha1
|
| pi | ≤ 2.5.0
| No fix yet |
Description
A Cross-Site Scripting (XSS) was discovered in pi-engine/pi 2.5.0. The vulnerability exists due to insufficient filtration of user-supplied data (preview) passed to the pi-develop/www/script/editor/markitup/preview/markdown.php URL. An attacker could execute arbitrary HTML and script code in a browser in the context of the vulnerable website.
NVD description
A Cross-Site Scripting (XSS) was discovered in pi-engine/pi 2.5.0. The vulnerability exists due to insufficient filtration of user-supplied data (preview) passed to the "pi-develop/www/script/editor/markitup/preview/markdown.php" URL. An attacker could execute arbitrary HTML and script code in a browser in the context of the vulnerable website.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free