In short
- CVE-2017-7391 is a MEDIUM (CVSS 6.1) vulnerability affecting dweeves/magmi, magmi (magmi project).
- Chance of exploitation in the next 30 days (EPSS): 8.3%, higher than 94.9% of all vulnerabilities.
- Fix: update to 0.7.24 or later.
| Package | Affected versions | Patched versions |
|---|
| dweeves/magmi Packagist | < 0.7.24
| 0.7.24
|
| magmi | = 0.7.22
| No fix yet |
Description
A Cross-Site Scripting (XSS) was discovered in Magmi 0.7.22. The vulnerability exists due to insufficient filtration of user-supplied data (prefix) passed to the magmi-git-master/magmi/web/ajax_gettime.php URL. An attacker could execute arbitrary HTML and script code in a browser in the context of the vulnerable website.
NVD description
A Cross-Site Scripting (XSS) was discovered in 'Magmi 0.7.22'. The vulnerability exists due to insufficient filtration of user-supplied data (prefix) passed to the 'magmi-git-master/magmi/web/ajax_gettime.php' URL. An attacker could execute arbitrary HTML and script code in a browser in the context of the vulnerable website.
More vulnerabilities in dweeves/magmi
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free