In short
- CVE-2017-7466 is a HIGH (CVSS 8.0) vulnerability affecting ansible, ansible (redhat), openstack (redhat).
- Chance of exploitation in the next 30 days (EPSS): 3.0%, higher than 87.5% of all vulnerabilities.
- Fix: update to 2.2.3.0, 2.3.0.0, 2.3 or later.
| Package | Affected versions | Patched versions |
|---|
| ansible PyPI | < 2.2.3.0< 2.3.0.0
| 2.2.3.02.3.0.0
|
| ansible | < 2.3
| 2.3
|
| openstack | = 10= 11
| No fix yet |
Description
Ansible before version 2.3 has an input validation vulnerability in the handling of data sent from client systems. An attacker with control over a client system being managed by Ansible, and the ability to send facts back to the Ansible server, could use this flaw to execute arbitrary code on the Ansible server using the Ansible server privileges.
NVD description
Ansible before version 2.3 has an input validation vulnerability in the handling of data sent from client systems. An attacker with control over a client system being managed by Ansible, and the ability to send facts back to the Ansible server, could use this flaw to execute arbitrary code on the Ansible server using the Ansible server privileges.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free