In short
- CVE-2017-8418 is a LOW (CVSS 3.3) vulnerability affecting rubocop, rubocop (rubocop project).
- Chance of exploitation in the next 30 days (EPSS): 0.41%, higher than 35.4% of all vulnerabilities.
- Fix: update to 0.49.0 or later.
| Package | Affected versions | Patched versions |
|---|
| rubocop RubyGems | < 0.49.0
| 0.49.0
|
| rubocop | ≤ 0.48.1
| No fix yet |
Description
RuboCop 0.48.1 and earlier does not use /tmp in safe way, allowing local users to exploit this to tamper with cache files belonging to other users.
NVD description
RuboCop 0.48.1 and earlier does not use /tmp in safe way, allowing local users to exploit this to tamper with cache files belonging to other users.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free